SS7 blog

Горна Диканя hi-tech

Студ …

No comments

Бахти студа настана :) . Днес едва направих едно RG навън.

А има толкова много работа тази седмица. Трябва да се пуснат поне 3-ма клиента до събота. Да се сложат кутии на два нови блока -87 и 88, в които досега нямаше мрежа. За кутия е и един блок наблизо в които има двама клиента и вече е за комутатор и ODF – ще минава оптика покрай него скоро. А мисля (мислех) декември да го ударя на почивка, ама май няма да ме огрее :( Всъщност иска ми се да забегна в най-забутаното планинско селце и да се отдам на медитация :) (другата дума за мързелуване) .

Някой беше питал как да се свърже с мен. Най-лесния и сигурен начи за това е на : stoilov at dupnica.net . Не ползвам skype, icq, mesenger и т.н. IM , щото зайни и незнайни люде не ме оставят на мира и не мога да свърша никаква работа. На едно място не се задържам, та и среща е трудно да се уреди (не е невъзможно де) , а пък GSM-a искрено го мразя. Вдигам само на познати номера и то съвсем не винаги. На фиксирания отговарям, но незнайно защо народа не ще да звъни на него !?!

Вестител нещо закъсняват с местенето на оптичния кабел. Аз си знаех, че няма да стане толкова бързо, ама ……. А се очертава раздвижване на пазара на едро, та кой знае, може да се уредим с по-голям капацитет, и втори доставчик.

То се е видяло, че LIR няма да ставаме (скоро), ама ще трябва да си купим няколко PI мрежи, щото ми писна с тия PA адреси.

Във връзка с една тема в клубовете на dir.bg ще напиша 2-3 думи за безжичните карти. По точно карти на 5Ghz , поддържащи turbo . За 2.4 Ghz съм писал вече – TP-LINK.

Та най-добрите карти на които съм попадал досега са Nortel. Има ги ето тук , ако не са свършили вече. 20 dB при турбо режим :

current-tx-powers: 6Mbps:20,9Mbps:20,12Mbps:20,18Mbps:20,24Mbps:20,36Mbps:19,48Mbps:17,54Mbps:16
Много добри карти са и PC-684HA , за съжаление доста скъпички :)

current-tx-powers: 6Mbps:21,9Mbps:21,12Mbps:21,18Mbps:21,24Mbps:21,36Mbps:21,48Mbps:20,54Mbps:19

Ползваме и няколко карти 3COM , те са 13-17 dB , но пък имат доста голяма чувствителност, също са доста скъпички :(

current-tx-powers: 6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:16,48Mbps:14,54Mbps:12

Вчера имаше кофти буря с много вятър, дъжд и сняг. Имаме една точка с антена само облъчвател и сигнал -67 dB . Вчера при обилен снеговалеж, сигнала намаля до -87 dB , съответно линка падна за 30-на минути. Та днес отидохме да подложим офсетова антена зад облъчвателя. Сигнала се качи на – 45 dB , което означава, че 60 см. офсетово огледало добавя 22 dB. Събрано с усилването на самия облъчвател (10 dB) дава много добър резултат – 32 dB за 60 см. офсетова антена.

На защитниците на плоския данък в Българския му вариант предлагам да прочетат ето тази статия от доц. Брусарски. И да обърнат специално внимание на термина “пределна полезност на дохода” .

Дори в БСП се намери един човек, които да каже истината за този данък. Публикация във в-к Стандарт . Може да не харесвам партията му, но определено уважавам г-н Близнашки за това, че е казал истината.

Нямам никакво желание да пиша по икономически теми, но изливащата се напоследък демагогия свързана с “плоския” данък ме отвращава.

Върти ми се един кофти въпрос напоследък :

Какво мислите ще стане с инфлацията след като правителството похарчи ударно 1 милиард лева ? Че нали тази година инфлацията е нисичка по принцип. А новогодишните увеличения на акциза за горивата ?

Ей това “бившите” комунисти изпростяха до безобразие. Или по точно – станаха прекалено нагли. И в двата случая са вредни за държавата.

Плоския данък щял да има ляв ефект :) . Мдаа, ще вземем повече данъци от бедните, за да ги дадем пак на бедните , ама един вид подаяние – видите ли – Вие зависите от нас,ние се грижим за Вас . Пък по между другото ще има нещо и за нас. Да пуснем търгче на ‘приятелска’ фирма и т.н.

А факта, че данъчната тежест се прехвърля върху тези с по-ниски (минимални) доходи за сметка на много богатите го премълчаваме, а ? Някак си не е удобно да го казваме.

Ама нали червения електорат простичък, та всичко минава за пред него. На следващите избори пак ще има будали да гласуват за тях. Ами гласувайте. Ще ви свалят и последната кожа от гърба.

Новия кмет на Дупница – Атанас Янев прекрати едно от червените безумия, сътворени от бившия кмет Първан Дангов, а именно – движението вече е двупосочно.

Поздравления !

А бившия кмет – Дангов, го издигат в БСП, като благодарност, че загуби изборите. Политик щял да става. А какъв беше досега бе ? Дангов – земи се гръмни – нищо не става от тебе.

по тоя свят. Особено във в-к Монитор

Някакъв измислен “компютърен специалист” a.k.a Йордан Йорданов е написал ТОВА нещо пълно с глупости. Неуважаемий “компютърен специалисте” , имам следните незначителни забележки към твоите писателски напъни :

1. Това, че google връща различни резултати в зависимост от държавата изобщо не е цензура. Политика на търсачката – ако не ти харесва – не я полваш. Никой нищо не ти цензурира. Ако искаш оригинална подредба на отговорите – отиваш на google.com/ncr и получаваш “нецензурирани” отговори.

2. Не, ‘официално филтриране’ няма по ‘целия свят’ , нито в Европа, нито в България. Посочената заповед за филтриране на аренабг беше незаконна (ченгета, кво да ги правиш, закона за тях е врата у поле) и половината доставчици не я изпълниха . Закона не позволява подобна филтрация !!!

3. Фирмите имат пълното право да администрират собствените си мрежи както намерят за добре. Спрели gepime.com , ами ще го спрат. Ти си отишъл да работиш, не да се правиш на Дон Жуан. Ако не ти харесва – напусни. Приятелю “компютърен специалист”, ако във трудовия ти договор присъства задължението на работодателя да ти осигурява интернет, тогава можеш да рониш крокодилски сълзи.Иначе – не, не можеш.

4. Как само искам orbitel.bg да те осъдят за тази ти лъжа :

“Например сайтът на фирма за фитнес оборудване (jk-fitness.com), който е с изцяло променено съдържание от месеци, за сърфиращите в Мрежата през фирмата-доставчик на Интернет Орбител все още изглежда, че не е бил променян изобщо.”

5. Чул си нещо за DNS, ама ни си разбрал що е то, нито със какво се то яде.

6. За спам листите , проксита, рутери също.

7. За мерудия прибавихме и авторските права, накъде без тях.

Срам, срам. Аз не бих се наричал “компютърен специалист. Пък и статии да публикувам в Монитор.

Поради различни причини се налага различно шейпване на българския и международния трафик. В мрежата има доста написано как става това с Линукс, но за Микротик няма :(

Да запълним тази празнина. Първата стъпка е да се опишат българските мрежи в :

ip firewall address-list>

/ ip firewall address-list
add list=bgnet address=62.44.96.0/19 comment=”" disabled=no
add list=bgnet address=62.73.64.0/18 comment=”" disabled=no
add list=bgnet address=62.176.64.0/18 comment=”" disabled=no
add list=bgnet address=62.200.195.0/24 comment=”" disabled=no
add list=bgnet address=62.204.128.0/19 comment=”" disabled=no
add list=bgnet address=62.213.160.0/19 comment=”" disabled=no

списък с българските мрежи може да се вземе от тук или от тук.

За автоматизиране на процеса може да се използва този скрипт (bash – linux) :

#!/bin/bash

file=/etc/bgnet.conf
line_count=`wc $file | awk ‘{ print $1 }’`
echo $line_count
for name in `seq $line_count`
do
read name
echo add list=bgnet address=$name
done
След това маркираме международните пакети със :

/ip firewall mangle

add chain=prerouting dst-address-list=!bgnet action=mark-packet new-packet-mark=int passthrough=yes comment=”inter-out” disabled=no
add chain=prerouting src-address-list=!bgnet action=mark-packet new-packet-mark=int passthrough=yes comment=”inter-in” disabled=no

Вече всеки международен пакет е маркиран със ‘int’ и въз основа на тази маркировка можем да шейпваме или рутираме . Шейпването става така :

add name=”nolimit-int” target-addresses=87.247.253.68/32,10.0.0.99/32 dst-address=0.0.0.0/0 interface=all parent=3_international packet-marks=int direction=both priority=7 queue=default/default limit-at=8000/8000 max-limit=256000/512000 total-queue=default disabled=no

Като допълнение можем да рутираме международния трафик през друг доставчик, например да пуснем само международния http трафик, но предварително трябва да маркираме само http трафика :

add chain=prerouting src-address=10.0.0.0/8 protocol=tcp dst-port=80 dst-address-list=!bgnet action=mark-routing new-routing-mark=web-int passthrough=yes comment=”" disabled=yes

add dst-address=0.0.0.0/0 gateway=78.40.140.1,78.40.140.1 check-gateway=ping scope=255 target-scope=10 routing-mark=web-int comment=”" disabled=no

Тези операции обаче изискват добър процесор. Ако трафика е голям трябва сериозна машина. Поради това ние ограничаваме общия трафик на една машина , а международния – на друга. При бъдещо натоварване се предвижда шейпване само на локалните рутери. Бордер-а вече 2-ри месец издъхва. Няколко часа дневно държи 100% натоварване и 100% RAM, но чакаме Вестител-а да преместят оптиката и тогава ще го сменим.

TP-LINK TL-WN651G

1 comment

Турбо версията на TP-LINK TL-WN551G. Поддържа superG 108 mbit . Работи с микротик – проверено.

# DEVICE VENDOR NAME IRQ
0 01:0c.0 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev: 120) 7
1 01:0b.0 Atheros Communications, Inc. AR5212 802.11abg NIC (rev: 1) 9 wn651g
2 01:08.0 Atheros Communications, Inc. unknown device (rev: 1) 10 wn551g

Мисля, че е няколко dB по чувствителна от WN551Gи поддържа компресия.

Бившите Linksys, вече Cisco продават най големите wifi боклуци .

Имахме един изостанал WRT54G в режим AP, към който имаше вързани 2 клиентски устройства. Преди 2 дни се обажда единия от клиентите и казва, че няма интернет. Гледам аз на статистиката – ужас – загуби – 80% :

7р

Другия клиент работи нормално. Това проверихме, онова проверихме всичко нормално – сигнала е добър, но на голям пакет загуби огромни.

Викам си аз, крайно време е да се разкара тоя линксис и да сложим микротик. Та днес сложихме една карта и изхвърлихме линксис-а . Връзката веднага светна :

1 ;;; simeon
center2vk-2.4g 00:4F:62:04:C9:4E no -71dBm… 36Mbps 6h5m13s
3 ;;; 7ma-rilska
center2vk-2.4g 00:0E:2E:AA:B9:3C no -74dBm… 36Mbps 1h4m27s

Няма загуби , тече 4-8 мбита трафик без проблеми. Както и трябва да е.

Понеже Linsys се води реномирана марка , пък тоя блог вече доста се търси по wifi, ще дам един безплатен съвет – бягайте далече от Linksys , ама много далече.

Днес преживяхме една syn flood атака от адрес : 72.12.88.18 , някъде в Оксфорд . Имаше syn, едновременно към цяла мрежа и по слабичките рутери взеха да се шашкат. Това си беше добър повод да направим ограничение по 100 конекции на клиент, че някой бяха се забравили .